Back to overview
Degraded

PowerBI degraded

Feb 27 at 09:00am AEDT

Resolved
Mar 01 at 02:44pm AEDT

Microsoft have advised us that this issue has now been remediated

Updated
Mar 01 at 09:00am AEDT

Microsoft have now agreed (on Friday morning Sydney time) that the issue raised by us on Tuesday is an ongoing issue in PowerBI which they believe has been caused by a regression in a recent release.

They are continuing to investigate and plan to implement a short term mitigation and medium term fix. They have also agreed to provide a root cause analysis once they know the cause.

Created
Feb 27 at 09:00am AEDT

We are receiving reports of degraded performance in PowerBI. There are no code changes on Data Studio and therefore we have logged this is a bug with Microsoft.