Back to overview
Degraded

SQL Server outage in West Europe

Feb 13 at 10:30pm AEDT

Resolved
Feb 14 at 03:17pm AEDT

Microsoft have published a Root Cause Analysis.

We are advised that they have identified and remediated the issue.

Impact Statement: Between 11:33 UTC and 17:00 UTC on 13 Feb 2024, some customers using SQL Database, Azure Synapse Analytics, Azure Database for MySQL, Azure Database for PostgreSQL services in the West Europe region may have experienced intermittent issues when performing service management operations.

This includes databases unpausing (required for Data Studio).

Updated
Feb 14 at 04:00am AEDT

Issue Resolved by Microsoft

Users of West Europe projects reported issues with Data Studio related to SQL Server connectivity (Data Studio/DAP showed SQL timeout errors)

The Data Studio L4 team investigated the Job Functions logs and observed there was a 3h window during which connection attempts to the West Europe databases failed. Data Studio uses a modern serverless architecture per Microsoft best practice, where resources turn off when not in use. Whilst Data Studio does have retry logic on waiting for the databases to turn back on, this only lasts for approximately 5 minutes. During the outage we observed that databases was unavailable for more than full 1 hour. In normal situations, it takes < 30s to connect, with Microsoft stating around 1 minute as their SLA.

The outage of the databases in West Europe was automatically resolved by Microsoft.

Upon further investigation there was a notified Microsoft event with SQL Control Plane Operations failing in West Europe (Tracking ID NKZQ-38Z) between 11:33 UTC and 17:00 UTC on 13 Feb 2024. There is no Post Incident Review with root cause provided by Microsoft at this point)

Actions taken:
We followed up with MSFT for a root cause which will be shared when available.
We also note that the v3.x projects, which no longer use SQL, were not affected by the outage above.
The Data Studio team are committed to providing a high availability application, with significant effort still being made to be resilient to outages in our cloud provider (Microsoft Azure).

Created
Feb 13 at 10:30pm AEDT

Users of West Europe projects reported issues with Data Studio related to SQL Server connectivity (Data Studio/DAP showed SQL timeout errors)