Back to overview
Degraded

PowerBI Outage

Jul 27 at 07:51pm AEST

Resolved
Jul 27 at 08:38pm AEST

This issue has now been resolved by Microsoft.

Created
Jul 27 at 07:51pm AEST

Power BI customers with Tenants located in the West US region may experience issues accessing service. Engineers are investigating the issue and an update will be provided soon.

https://powerbi.microsoft.com/en-us/support/